Time to Upgrade your CLI!

We've released version 1.3.0 of Ghost-CLI — with some very important updates...

Please upgrade as soon as you can!

Highlights

  • [New] SSL renewal fix & migration
  • [New] Added Ghost compatibility check
  • [Improved] CLI upgrade notifications
  • [Fixed] Removed knex-migrator dependency

In Detail

1.3.0 is an important release, for the following reasons:

  • The SSL renewal issue will be automatically fixed when you run ghost update or if you run ghost migrate, see below for more info.
  • Ghost-CLI now knows if it is out-of-date and prompts you to upgrade
  • Removal of the knex-migrator dependency means less compatibility issues with nvm, sqlite, etc.

SSL Renewal

A month ago we received a report that SSL certificate renewal does complete successfully with <=1.1.3. Although the certificates were regenerated correctly, nginx was not restarted, meaning the new certificates were not picked up.

If you're reading this and your blog is offline with the error NET::ERR_CERT_DATE_INVALID, run sudo nginx -s reload to fix the problem and then upgrade Ghost-CLI to ensure it doesn't happen before..

If your blog was created with the CLI <= 1.1.3 please upgrade now to the latest version and then run either ghost migrate or ghost update.

Our CLI docs have been updated. If you run into problems, please swing by our slack channel or raise a bug issue here.

Removal of knex-migrator

If you used Ghost-CLI before and ran into difficulty managing node versions, using nvm, or with sqlite3 (even if you weren't using sqlite3), you should find that Ghost-CLI is now much easier to use.

How to Upgrade

For npm users, run:

sudo npm i -g [email protected]

Followed by

ghost migrate

For yarn users, run:

sudo yarn global add [email protected]

Followed by

ghost migrate

The full upgrade guide lives here: https://docs.ghost.org/docs/upgrade#section-upgrading-ghost-cli