Ghost 0.5.10

Ghost 0.5.10 is now available on GitHub, npm and Ghost.org. We're back to our shorter release cycles, Ghost 0.5.10 is an incremental update containing several small improvements and fixes as well as tentative support for Node v0.12 and io.js-v1.2.

Highlights

  • [New] User help menu
  • [New] Support for Node v0.12 & io.js-v1.2
  • [Fixed] Trailing slashes added to images in RSS feed
  • [Fixed] Navigation menu display issue in Firefox and IE
  • [Fixed] Navigation menu support for mailto links
  • [Fixed] Emoji appearing instead of icons on iPad

You can see the full change log for the full details of every change included in this release.

Node v0.12 and io.js-v1.2 Support

The pre-built Ghost zips will now install and run on Node v0.12 and io.js-v1.2. Ghost may install on other versions of io.js if the sqlite3 binaries are available, but only v1.2 is officially tested.

If you are attempting to build Ghost from source rather than using the prebuilt zip files, you are more likely to run into install problems if you are using Node v0.12 or io.js. Ghost depends on node-sass, which only has binaries available for io.js v1.2. In the event that you do run into issues, please use our support forum to seek help.

How to Upgrade

All Ghost(Pro) users are being automatically updated and will be running Ghost 0.5.10 shortly. You're welcome :)

For people running Ghost on their own servers, you can download Ghost 0.5.10 and then check out the upgrade documentation over on our support site. If you've missed out a version or two, don't worry you can upgrade directly from any 0.5.x version straight to 0.5.10.

Enjoy!

Credits

This release was lovingly crafted by Hannah Wolfe, Paul Adam Davis, Felix Rieseberg, Fabian Becker and (last but not least) John O'Nolan.