Product Dev Back to Ghost

Ghost 0.11.4

Ghost 0.11.4 is now available on GitHub, npm and Ghost.org. The main contents are the removal of Node v0.12 support and the new redirects feature.

Highlights

  • [New] ✨ Define redirects as JSON file
  • [New] ✨ Make AMP optional
  • [Removed] ⬇️ Node v0.12.x support - Node v0.12 is no longer maintained
  • [Fixed] Import subscribers on database import
  • [Fixed] Fix admin redirect, when using a subdirectory
  • [Security] Expand subscriber email validation
  • [Security] Escape sameAs for structured data
  • [Security] Detect symlinks when uploading themes via the admin panel
  • many dependency updates

You can see the full change log for the details of all changes included in this release.

In Detail

Ghost no longer supports Node.js v0.12. It's is no longer maintained as of 31st December 2016. We will continue to recommend using Node v4 with Ghost for the time being - even that this version is not the version recommended for most users by Node.js, it's v6.

Our Node version support follows the Node.js LTS strategy. Full details can always be found at: http://support.ghost.org/supported-node-versions/.

Furthermore, this release contains two new features.

Redirects

You can now add a redirects JSON file to your content folder to define your own HTTP redirects for your blog. We have written a redirects support guide for it.

AMP is now optional

You can enable or disable AMP in the admin panel under Settings - General - AMP support. If you disable amp, all amp requests will render a 404 page.

How to Upgrade

All Ghost(Pro) users are being automatically updated and will be running Ghost 0.11.4 shortly. You're welcome :)

For people running Ghost on their own servers, you can download Ghost 0.11.4 and then check out the upgrade documentation over on our support site.

Enjoy!

Credits

Kevin Ansfield, Aileen Nowak, John O'Nolan, Austin Burdine, 唐佳诚 , Vivek Kannan, Kenneth Ashley, John O'Mahoney, Hannah Wolfe and Katharina Irrgang